Your screen resolution is below the minimum required for Paltalk Express. Click on the link below to start using our new 'low screen-resolution' client. It is recommended that you disable your pop-up blocker before proceeding.

Click here for our new 'low screen-resolution' Paltalk Express client